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The ENVI® Pocket Guide is a quick reference booklet not intended to be
read from cover to cover, although it can be. The intent is to provide users
with succinct steps on how to accomplish common tasks in ENVI.
If you need or desire comprehensive explanations of tasks in this guide,
refer to the following resources:
ENVI Documentation Center

ENVI Help Articles

harrisgeospatial.com/docs

harrisgeospatial.com/Support

ENVI Tutorials

Tech Support

harrisgeospatial.com/docs/tutorials.html

(+1)303-413-3920

ENVI Videos

Email Support

harrisgeospatial.com/Learn/Videos.aspx

support@harrisgeospatial.com

Computer Based Training
harrisgeospatial.com/Learn/Training/cbt.aspx
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GETTING STARTED
OPENING ENVI
1. Please reference ENVI Pocket Guide Volume 1 | BASICS if you need
instructions on how to open ENVI, load and remove data, or descriptions
of interface components and basic data preparation procedures.

ENVI Pocket Guide Volume 1 | BASICS
provides an introduction to familiarize users with common methods
for opening ENVI, loading data, navigating, and performing stretches.
You are currently referencing
ENVI Pocket Guide Volume 2 | INTERMEDIATE
which expounds a step further on intermediate procedures using ENVI,
IDL and ENVI LiDAR, assuming you have already mastered the basics.
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GRID REFERENCE
1. Load any image (nadr, off-nadr, referenced or unreferenced) into ENVI,
then right click the image in the table of contents and select Zoom to
Layer Extent.
2. Next click the center of
the image and use the
mouse wheel to zoom
out until the image’s
edges are in view.
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If your image does not have a spatial reference you will not be able to
record coordinates, but you will be able to count features and record
File X,Y. Toggle check boxes next to Symbol, Label, Description,
Count or Coordinates to determine which attributes will be labeled.

GRID REFERENCE

3. Click the Feature Counting Tool icon to open the Feature Counting
Dialog Window. Right Click Description to turn on coordinates or
File (X,Y) for unreferenced images.
4. By default Grid is
set to 4 x 4, but
you may adjust
by entering new
values. Turn
values on
and off by
toggling the
check box.
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GRID REFERENCE

5.Click the Feature Counting Properties icon to customize properties
such as feature name, font size, symbol, label position, label show and
count show.
6. Close Properties.
Add other feature
categories by pressing
Add Feature icon.
By default new features
will be named ‘Feature
1’. Highlight the text
then type to rename.

8

8. As features are counted you may click the Description attribute and
type in associated information.
9.You may delete mistakes by highlighting row(s) and pressing
icon to delete individually or
icon to delete all.

GRID REFERENCE

7. Select the feature you’d like to start counting by using the drop down
arrow and begin counting features by clicking your image.

delete

10. To add a geographic grid click
then click Add Grid Lines
from the dropdown menu. The new grid often defaults to WGS 1984
Web Mercator Projection.
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GRID REFERENCE

11. To customize the newly added grid go to the Layer Manager, right
click the Grid[…], then click Properties. Here you may change the
Coordinate System, Text and Line Color, XY Spacing and other items
in the following graphic:
12. Once satisfied with edits, from
the Feature Counting Tool
click File> Export> Shapefile or
Report (.txt).
13. Next go to the main ENVI
interface and click File> Chip
View To >PowerPoint or PDF
for a finished product.
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GRID REFERENCE

Example NADR with Reference and Off NADR without Reference:
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BAND MATH
1. Load a multi-spectral or hyper-spectral
image into ENVI then select Band
Algebra > Band Math from the Toolbox.
2. O
 nce the Band Math dialog box
appears, enter any simple or complex
mathematical expression using b#
variables to represent the bands you
want to manipulate. Replace # with the
band number as seen in the example.

Band Math is a method used to create new raster data by performing
complex or simple mathematical functions on existing bands available in
one or more geographically referenced images. Analysts will be able to
compress data into isolated values of interest such as NDVI (Normalized
Vegetation Index) for example.
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BAND MATH

3. Next click Add to List then OK
to open the Variables to Bands
Paring dialog.
4. Initially the variables are undefined. One by one, highlight each
Variable used in expression then
click the corresponding band in
the Available Bands List to define
the variables.
5. Click Choose Output Filename
and name your new image or
elect to process in memory then
Click OK.

13

BAND MATH
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6. You may check your
results by linking
two views; one view
with a corresponding
spectral composite
that matches the
bands manipulated
in your expression,
and the other
containing the output
image, and then use
the Cursor Value
icon to confirm
results.

BAND MATH

Example Band Math on Landsat 7 Input b4 + b3 + b2 = Output:
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LAYER STACKING
1. Open each of the images you
wish to Layer Stack then click
Raster Management > Layer
Stacking in the Toolbox.
2. Set desired Output Map
Projection on the Layer Stacking
Parameters dialog, then Click
Import File

Layer Stacking is used to construct new multi-band imagery from
georeferenced images of many pixel sizes, extents, and projections.
Input bands are resampled and re-projected to a user defined pixel size
and spatial reference system. The resulting image will comprise the
extent of all images or only the region of overlap.
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LAYER STACKING

3. U
 sing the shift key or
CTRL, highlight each
image you wish to
stack, and then click
OK.
4.Next click Reorder
Files and then drag
and drop the bands in
the proper order from
least to greatest then
click OK.
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LAYER STACKING

5. Choose output map projection from the list, set the X Pixel Size and Y
Pixel Size or accept defaults, and then choose the resampling method:
•Nearest Neighbor:
Uses the nearest pixel
without any interpolation
•B
 ilinear: Performs a
linear interpolation
using four pixels
•C
 ubic Convolution: Uses
16 pixels to approximate
the sync function using
cubic polynomials
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• Inclusive: geographic extent encompasses all the input file extents
• Exclusive: contains only data extent where there is spatial overlap

LAYER STACKING

6. Select Inclusive or Exclusive to stipulate the output file extent:

7. Click Choose Output Filename and name your new image or elect to
process in memory then Click OK.
Example Layer Stack on Landsat 7 bands 1,2,3,4,5,7:
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SWIR BANDS
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Short-Wave Infrared (SWIR) Bands can be exploited to differentiate
between man-made materials that might otherwise be classified improperly
when using visible and/or other Multi-Spectral Imagery (MSI) Bands
because atmospheric aerosols have a lesser impact on SWIR bands. The
following sensors collect SWIR Information: Worldview 3, Landsat (4, 5,
7 and 8), SPOT (4 and 5), Terra & Aqua (MODIS/ ASTER), and VIIRS

SWIR BANDS

1. Load an atmospherically corrected SWIR image into ENVI. ENVI
will automatically load it as a Grayscale image. If your image is not
atmospherically corrected yet, type “QUAC” in the Toolbox search
window to locate the Quick Atmospheric Correction tool, then run
the image through the QUAC wizard. Otherwise continue.
2. O
 nce the QUAC SWIR image is loaded take some time to get familiar
with the image using the navigation tools. Next you will explore each
SWIR band. Since the image is in grayscale bright spots reflect more
in each wavelength and dark pixels absorbs and reflect less, but gray
regions slightly absorb, scatter, and/or reflect.
3. N
 ext right click the SWIR image in the table of contents and select
Band Animation. Expand the Band animation window if need be by
dragging from the corners.
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SWIR BANDS

4. From left to right, the Play Buttons
will allow you to play backward,
or pause or play forward through each SWIR band to visualize which
bands show high reflectance for the feature(s) you are interested in.

5. Click the tool icon
then > Annotate>
Frame number to dynamically display the
SWIR band number while animation is
playing. Use the select icon to drag the
annotation to desired position.
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SWIR BANDS

6. Once you click Play forward or backward, you may adjust
playback speed using the delay dropdown menu.
7.Next right click the SWIR_<your image name>.series in
the table of contents and select Change Color Table >
Rainbow. This technique makes it easier to identify high
reflectance pixels per SWIR band. Once you’ve identified
high reflectance bands for the material you’re interested in,
close the Band Animation dialog.
8.Next click the Data Manager and load a SWIR False Color Composite
using the bands you’ve previously identified. In this example I’m displaying
SWIR 7 as Red, SWIR 1 as Green and SWIR 5 as Blue. Click Load Data to
either the same view or a linked view.
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SWIR BANDS

9. If you have multispectral
imagery over the same
region, load your MSI in
a True Color Composite
into the same view or a
linked view.
10. Next highlight the MSI
True Color Composite
in the table of contents
and press Alt, Z
simultaneously on
your keyboard to open
a Spectral profile. Do
the same for the SWIR
False Color Composite.
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SWIR BANDS

11. Position the two
spectral profiles side
by side then select
and compare spectra
via left click with the
select tool while
simultaneously
pressing the Shift key.

12. In the above example the image to the left is an MSI True Color Composite
and the Image to the right is a SWIR 751 False Color Composite. Notice
how the roof in the cross hair appears to be the same material as the
left adjacent roof until analyzing in the SWIR image which visually and
spectrally draws out the difference in material.
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SWIR BANDS

13. If you wish to classify your SWIR Image at this point, type Spectral
Angle Mapper Classification in the Toolbox search window and double
click the Spectral Angle Mapper Classification Tool. For a comprehensive tutorial and explanation of this tool, visit the ENVI online
Documentation Center at:
www.harrisgeospatial.com/docs/spectralanglemapper.html

Visit http://speclab.cr.usgs.gov/ for a comprehensive list of materials in
association with best SWIR bands used to identify specific materials.
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SPECTRAL ANALYSIS
Spectral Profile Interface

Some numbers represent GUI groups separated by commas from left to right.

1. Spectral Profile with X & Y axis

8. Choose X axis

2. Remove selected curve, Remove
all curves, Edit data value

9. (X) Electromagnetic Spectrum/
Wavelengths in nanometers

3. Show/Hide Properties

10. (Y) Data Value

4. List of collected spectra/ classes

11. Import ASCII or Spectral library,
Export ASCII, Spectral Library,
PDF, Image or PPT, Profile
Window Options

5. Show/High extra info, General
Properties, Curve/ Spectra
properties
6. S tack plots, Reset plot range
7. C
 hoose Y axis
28

12. 1 x sample spectra plot (select
multiple by clicking image
while holding Shift)
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SPECTRAL ANALYSIS

1. Load your SWIR 751 band
combination False Color
Composite image into ENVI
and then highlight it in the
table of contents then go
to the main menu and click
Display > 2D Scatter Plot.

Short-Wave Infrared (SWIR) Bands will be used again in this section to
further investigate the differences in material using 2D Scatter Plot and
the Spectral Profile in tandem. These methods can be applied on any
image containing more than 1 band.
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SPECTRAL ANALYSIS

2.Take a moment to hover your mouse over each icon on the Scatter
Plot dialog to read the Tooltips. Then toggle the Density Slice icon to
color your plot. You can change the color scheme by clicking Options
> Change Density Slice Lookup. Leave Full Band unchecked so you can
zoom into your scatter plot and imagery in tandem using the mouse
wheel or check it to maintain the full extent of the plot when zooming
in and out of the imagery.
3. Next highlight the default Class 1 and rename it to whatever material
you wish to compare then click the
Add Class icon to add more
spectra classes for comparison. Name classes accordingly. In this example we will compare Roof Type 1 & 2.
4. C
 hange Scatter plot bands by clicking File > Select New Band X or
Y-Axis. The example plot shows SWIR 1 on X and SWIR 5 on Y.
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SPECTRAL ANALYSIS
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5. Right click in the Scatter
Plot dialog and select
the patch size you
desire. Click the Class
dropdown window and
ensure you are working
with the first class.
Then, within the Scatter
Plot window hold CTRL
and left click and move
around the plot. Notice
the corresponding pixels
dynamically highlight
within the image as you
move your mouse.

7. Now within your ENVI View first ensure the .2D Scatter Plot icon is
active. Then right click the image and select Cursor Mode > Region of
interest. Feel free to play around with the other cursor modes by holding
left click as you drag the mouse around the image while observing the
scatter plot.

SPECTRAL ANALYSIS

6. Hold left click within the scatter plot and draw a polygon around the
same pixels to select them. Next right click and select clear class.

8. While in Region of Interest (ROI) cursor mode draw a polygon around
your first spectra sample by either left clicking individual vertices or
holding left click to freehand draw. Double click to finish.
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SPECTRAL ANALYSIS
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9. W ithin the Scatter Plot window use the
drop down to select the next class then
repeat step 8 to collect a sample.
10. Next right click within
the Scatter Plot window
and select Mean all. This
gives you the statistical
mean for all spectra
captured within the
class ROI’s.

SPECTRAL ANALYSIS

11. Next hold shift key and
right click several disparate
pixels within the Scatter
Plot to show a graphical
comparison of mean
deviation among the spectra
in question. This indicates
the degree of correlation
between the X and Y
bands of choice.
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SPECTRAL ANALYSIS

12. L astly right click Classes
within the ENVI table of
contents and select Statistics
for All Classes then select
the SWIR image in the File
selection window and hit OK.

You may save your findings to a Spectral Library for future comparisons.
Standard Deviation is the average distance to mean for the spectral
material in question. Export the following report by clicking
File > Export to Text File.
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IMAGE CALIBRATE
1. Open your metadata file, for example
*****_MTL.txt in ENVI. This file
populates the associated imagery
in your Data Manager.
2. N
 ext right click the multi-band
image in the Data Manager and
load a True Color composite.
Spectral reflectance curves are used to distinguish materials that make
up the Earth’s surface. Spectral libraries are primarily created in the field
using a spectrometer instrument. Satellite imagery requires calibration
before comparing against spectral libraries collected in the field because
satellites measure radiance which is often tainted by occurrences and
nuances such as aerosols, shadows, clouds, the Sun’s position, and more
thus resulting in distortion.
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IMAGE CALIBRATE
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3. Type QUAC in the Toolbox search window and then double click
Quick Atmospheric Correction (QUAC) to launch the QUAC wizard.

IMAGE CALIBRATE

4. Highlight the Multispectral image in the Select Input Data then click Spatial
Subset. Draw a box around the region you will analyze, avoiding heavily
clouded areas and areas with large bodies of water, then click OK.
5. In the next dialog the default
Sensor Type is derived from
metadata. Name your output
file and ensure its being saved
in a desired location. Toggle
Preview and click OK if satisfied with preview.
6.Link your views and inspect
results by analyzing each
Spectral Profile.

39

IMAGE CALIBRATE
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LANDSAT Before & After Atmospheric Correction:
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LIDAR FEATURE EXTRACTION
ENVI LiDAR Interface

Some numbers represent GUI groups separated by commas from left to right.
1. New Project, open Project or LAS, Process Data, QA Mode, QA Mode
with Center Line, 3D Viewer, Select Cross Section, Cross Section Top
View, Reset Perspective View, Reset Isometric View, Measurement Tool,
Height Palette Editor, Color by Height, Color by Classification, Shade
by Intensity, Color by RGB, Color by Viewshed Analysis, Filter Points by
Height, Launch Products in ENVI, Launch Products in ArcMap,
Screenshot to PowerPoint
2. M
 ain Viewer Window

4. Navigation Tools, Navigation Window

3. Session Operations Log

5. Layer Manager

For a more comprehensive understanding of ENVI LiDAR visit the online
Documentation Center, Videos and Tutorials.
42
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LIDAR FEATURE EXTRACTION

1.Open ENVI LiDAR by clicking Start > All Programs > ENVI 5.x > ENVI for
ArcGIS® > ENVI LiDAR 5.x (32-bit).

2. Next click File > New Project and then navigate to the directory you
wish to save your project and name it yourProjectName.ini. The .ini is
the file extension used to save LiDAR Project sessions. You may open
existing projects by locating .ini files via File > Open.
3. Click OK when prompted to select the LAS or other data to be imported
for your project. Navigate to the location of your LAS file and open it. You
will then be prompted Yes or No for additional data. Click No if satisfied.
44

LIDAR FEATURE EXTRACTION

4. If the proper coordinate system is attributed in your LAS metadata
you will be prompted to confirm its usage. Otherwise you will need to
designate a Coordinate System in the Convert Format dialog. Choose
the input data’s projection and the click OK.
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LIDAR FEATURE EXTRACTION
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5. You may now change the point
cloud symbology by clicking the
Height Palette Editor:

or Color by Height, Color by
Classification, Shade by Intensity, and Color by RGB if the LAS
contains the necessary metadata. In the Height Palette Editor
click Load palette and select
Earthtones.

LIDAR FEATURE EXTRACTION

6. Next, in the Navigation
Window, left click and drag
a rectangle around the
region you are interested
in extracting or the entire
frame.
7. Next click the Process Data
icon
which brings up
the Project Properties
dialog window.
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LIDAR FEATURE EXTRACTION

8. If you decide to toggle Produce Point
Cloud keep in mind that ENVI LiDAR
will generate a new classified Point
Cloud which coincides with the
American Society for Photogrammetry
and Remote Sensing (ASPRS) LAS
Specification 1.x.
9. In this exercise we are interested in
extracting buildings and trees. In the
Project Properties dialog toggle Produce
Buildings and Produce Trees. Adjust
File Size Limit if necessary or accept the
default 500Mb. Note the output data
will be saved to the Products Folder
which was automatically generated
within the directory which contains
your ProjectName.ini.
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LIDAR FEATURE EXTRACTION

10. Next click Start Processing.
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LIDAR FEATURE EXTRACTION

11. ENVI LiDAR will default to QA
Mode once processing is complete.
While in QA Mode, double click
any of the Vector Layers within the
Main Viewer Window and select
from the following options to make
any necessary corrections:

12. Once satisfied with edits you may toggle the 3D Viewer
icon for
a 3D Model of your data or you may Launch Products in ENVI, or
Launch Products in ArcMap for further analysis or Screenshot to
PowerPoint using these icons:
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LIDAR FEATURE EXTRACTION

Sample 3D View from Point Cloud:
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BATCH PROCESSING
IDL (Interactive Data Language) is the programming language that
drives ENVI. Users can use IDL alone or in tandem with ENVI by use
of the ENVI API. The ENVI API uses an object oriented methodology
to manage and manipulate data, views and the overall state of the
application. Many workflows require routine steps the user must
perform whenever he or she wants a particular product or result.
Such workflows can be automated using IDL ENVITasks, thus improving
efficiency while mitigating user error. This approach is commonly
referred to as Batch Processing which generally means to collect a
set of instructions or jobs and then execute the set without user
interference. The next example demonstrates how to Batch subset
and reproject every image in a specified directory.
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Interface Key on page 54 u
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BATCH PROCESSING

IDL Workbench Interface

Some numbers represent GUI groups separated by commas from left to right.
1. Main

Menu/Toolbar: New Program, New Project, Open, Save, Cut,
Copy, Paste, Undo, Redo, Back, Forward, Compile, Run, Stop, Step In,
Step Over, Step Out, Call Stack, Reset
2. P rogram Editor Window
3. IDL Console/ Sandbox

4. Tabs: Project, Outline,
Variables | List of Project Variables

Explore Getting Started with IDL Programming manual or ENVI Online
Help for a more comprehensive explanation of the IDL Workbench.
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2. Next click the

icon to create a new empty program script.

3. Click the File > Save As then navigate to your desired directory and
name the program batchReprojectDirectory.pro and click Save.

BATCH PROCESSING

1. Open IDL by clicking Start > All Programs > IDL 8.x > IDL 8.x.

A general understanding of object oriented programming and coding
conventions are useful when working with IDL. The following resources
will be of use in building your understanding:
Object Oriented Programming:
www.geo.mtu.edu/geoschem/docs/IDL_Manuals/OBJECT%20PROGRAMMING.pdf

Coding Conventions:
www.harrisgeospatial.com/docs/case_versus_switch.html
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BATCH PROCESSING

4. Right click in the Program Editor
Window, click Preferences then
check Show line numbers. This will
help identify errors if debugging is
necessary. Click OK.
5. In the Program Editor Window,
enter the following lines of code:

6. The code in blue must match the
filename. All IDL programs start
and end in this way.
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BATCH PROCESSING

7. Next we will use ;
which indicates
non-executable
comments, to write
the steps we want to
perform in pseudo
code. This ensures
good logic and code
readability for other
users. To subset and
reproject the contents
of a desired directory
the following steps
must occur
It is important to note the \01Batch directory and output \Reprojected
directory were already created. To prevent path typo’s drag the folder
into the IDL Console/ Sandbox then copy and paste the resulting string
into your code.
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BATCH PROCESSING
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8. We can now begin writing actual code to accomplish each
commented step.
9. The first four
comments are as
simple as declaring
variables which start
the application, sets
the input directory,
sets the output
directory and creates
a file list array object
by searching the
input directory for
wildcard/all files
indicated by *
meaning all files
ending in .tif.

BATCH PROCESSING

10. We will now use a “for loop” to iterate, though our list of files stored in
the fileList object and subset & reproject at each iteration.

11. At this point we are now ready to take advantage of
ENVITask snippets. Open Google Chrome and navigate to:
http://www.harrisgeospatial.com/docs/envitask.html. Scroll below
TaskName until you find a task applicable to the problem we need to
solve. Click ReprojectRaster and notice there is a snippet which already
accomplishes 90% of what we need to do. Highlight and copy the
ENVITask snippet from Raster = e.OpenRaster(File) to the last line.
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BATCH PROCESSING
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12. Go back to IDL Program
Editor Window and
highlight our last 3
comments and then
paste the ENVITask
snippet. Afterwards
highlight any of the
newly pasted code not
indented properly and
hit the tab key until
properly indented under
the for loop then type
endfor as shown.

BATCH PROCESSING

13. Next modify the ENVITask snippet by changing parameters such as
Sub_Rect and COORD_SYS_CODE to coincide with your data. The
subset rectangle’s upper left and lower right can be obtained using
the Cursor Value in ENVI. To obtain your desired COORD_SYS_CODE
navigate to C:\Program Files\Exelis\IDL85\resource\pedata\predefined
and search either of the two text files in WordPad using CTRL + F.
Do not Modify these files.
14. Lastly add the following lines of code to write the new output rasters
then hit the compile button and check the IDL Console/ Sandbox
for any errors. Red in the Console indicates errors and green indicates
a successful compile:

15. If your program has errors use the line number in the error message to
address the issue. Otherwise click run to execute the program.
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BATCH PROCESSING
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Complete Batch Subset & Reproject Directory Example:

BATCH PROCESSING
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BATCH PROCESSING
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GEOSPATIAL DATA,
ANALYTICS, AND
CUSTOM SOLUTIONS
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From sensors and software to actionable
information, Harris Geospatial Solutions
helps you make informed decisions – when
and where they are needed.

HarrisGeospatial.com

