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The ENVI® Pocket Guide is a quick reference booklet not intended to be
read from cover to cover although it can be. The intent is to provide users
succinct steps on how to accomplish common tasks in ENVI.
If you need or desire comprehensive explanations of
tasks from this guide refer to the following resources:
ENVI Documentation Center

ENVI Help Articles

harrisgeospatial.com/docs

harrisgeospatial.com/Support

ENV Tutorials

Tech Support

harrisgeospatial.com/docs/tutorials.html

(+1)303-413-3920

ENVI Videos

Email Support

harrisgeospatial.com/Learn/Videos.aspx

support@harrisgeospatial.com

Computer Based Training
harrisgeospatial.com/Learn/Training/cbt.aspx
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ENVI® INTERFACE KEY
Some numbers represent GUI groups separated by commas from left to right.
1. O
 pen file, Data manager, Chip
extent to new file

9. Tools/ Toolbox; Image Processing
& Tools Search*

2. Cursor Value, Pan, Fly, Rotate

10. 3 x Inputs for Cursor Value;
Right click to personalize

3. Z oom; Fixed In, Fixed Out, Full
Extent, Percent/ Ratio
4. North Up, Type or Preset Angle

12. Brightness

5. P rofile; Spectral Profile, Scatter
Plot, ROI, Feature Count

13. Contrast

6. Digitizing; Vectors, Annotations
7. Go To Coordinate
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11. Layer Manager

8. T ransparency; portal, blend,
flicker, swipe & mensuration

14. Histogram Stretch
15. Sharpen
16. Data Viewer; Use View from
Main Menu to add multiple
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GETTING STARTED
OPENING ENVI
1. On Windows OS click Start > All Programs > ENVI 5.x > ENVI for
ArcGIS® > ENVI 5.x (32-Bit). This method allows users to interface
with ArcMap.
2. To open ENVI in (64-Bit) mode click Start > All Programs > ENVI 5.x >
64-Bit > ENVI 5.x (64-Bit). This method DOES NOT allow users to
interface with ArcMap.
3. To open ENVI programmatically via IDL click Start > All Programs > IDL
8.x > IDL 8.x. The IDL window will appear. Within the IDL Console Tab
type the following code: IDL> E = ENVI()
4. Hit ENTER and ENVI will soon launch.
This is an introduction to familiarize users with common methods for
opening ENVI, loading data, navigating, and performing stretches.
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GETTING STARTED

LOADING & REMOVING DATA
5. To load data click the Open File icon
. An explorer window will open.
Navigate to the disk location
of the file you wish to open.
6. Click the file and click Open. ENVI’s
native file format is .dat but ENVI
recognizes and reads most common
formats such as: (.img, .ntf, rpf,
.tiff, .las, .dt, dppdb, .sid, .shp,
.evf) and many more.
7. Another method is by clicking the
Data Manager icon . Click Data
Manager and the dialog appears,
as seen on the previous page.

Windows Data Drag & Drop
Functionality is fully supported
in ENVI.
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GETTING STARTED

8. This allows users to Load additional layers by clicking
or explore
different band combinations within the current view or a new view
via intuitive manipulation and clicking Load Data.
9. Provided complete metadata users can also
Right Click existing layers to load preset band
combinations such as:
10. Users may also use the Data Manager
to perform the following:
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11. Use ENVI’s intuitive navigation tools to perform the following
within a view:

GETTING STARTED

NAVIGATING WITHIN A VIEW

12. Use ENVI’s intuitive Image Display tools to perform the following
within a view:
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MOSAIC
1. From the Toolbox, select Mosaicking
> Seamless Mosaic. The Seamless
Mosaic panel appears. You will set
all mosaic options within this single
panel. Click the Help button in the
lower-left corner of the panel if you
have further questions.
2. Click the Add Scenes button

.

3. Click the Open File icon
in the
File Selection dialog. A file selection
dialog appears.
Before beginning, some imagery requires preparation such as cropping
to remove distorted edges to ensure optimal output results.
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MOSAIC

4. Navigate to the folder that contains the image data, and use the Ctrl
or Shift key to select the files you need to mosaic. Click Open. The File
Selection dialog lists all selected scenes.
5. Click the Select All button.
6. Click OK.
7. Your dialog should now
look similar to the example
on this page. Highlight
all images using the main
column.
8. Right Click the Data Ignore
Value column header and
set your value. In most cases
0 will be used.
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MOSAIC

9. Next highlight all images then Right Click > Feathering Distance and
set the value between 10-20 pixels or more depending on image quality
and resolution.
10. Click the Color Correction Tab and toggle Histogram Matching.
Go back to Main Tab and set your desired reference image under
the Color Matching Action column. All others will be matched.
11. Next click the Seamless dropdown arrow and select Auto Generate
Seamlines. Then Toggle the Show Preview radial button.
12. The system may take a few minutes to generate a preview depending
on your system specifications. Use the zoom Tools to visually inspect
before exporting.
13. If you are not satisfied during visual inspection go back to the
Main tab and tweak the reference image under the Color Matching
Action column and/ or adjust Feathering Distances. If Ignoring 0 Value
doesn’t completely eliminated edge noise you may need to crop the
input image(s) in question before mosaicking.
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MOSAIC

14. If you are satisfied with the preview proceed to the Export Tab.
(Optional) Use Crop Tool before exporting to designate a perfectly
square or rectangle output. Then select ENVI or TIFF Output format.
Choose desired Resample Method. Browse to your Output Directory,
name the output then click Finished.
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SUBSET
1. Open the ROI Tool and Draw a square or
polygon over the extent of the image you
want to subset. Double Click when satisfied
with drawing. Name the ROI you’ve just
created or leave it set to the default ROI #1.
2. From the Toolbox, select Regions of
Interest > Subset Data from ROIs
3. Under Select Input File highlight the
image that will be subset.
Subset will be performed using Regions of
Interest (ROI). Supported ROI inputs include
.xml files created with the ROI Tool, .shp
files, and ENVI Classic .roi and .evf files.
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SUBSET

4. The Select Input File to Subset via ROI dialog also gives you the option
to Select By: File or Band using this
button. You may also specify
bands by clicking the Spectral Subset button.
5. Accept all defaults and Click OK.
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SUBSET

6. H
 ighlight ROI #1 on the Spatial
Subset via ROI Parameters
dialog.
7. Enter Output Filename by
clicking Choose.
8. Navigate to desired output
directory and name the file
something like “subset.dat”
as seen in the example.
9. Click OK
10. The newly created subset will
be added to your View once
processing is complete.
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ORTHORECTIFY
1. Open the image you will orthorectify along with the associated DEM
if you have one.
2. From the Toolbox, select Geometric
Correction > Orthorectification > RPC
Orthorectification Workflow. The File
Selection dialog will appear.
3. Click the Browse button to select
your image and your DEM. If you
do not have a DEM use the default
GMTED2010.jp2 provided by ENVI.
To perform orthorectification the input image must have Rational Polynomial
Coefficients (RPC). Examine the metadata to ensure this information is present.
If you do not have elevation data ENVI provides a default 30 arc seconds (1km)
DEM called GMTED2010.jp2 which is saved during software installation.
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ORTHORECTIFY

4. Click Next to proceed to RPC Refinement. If you have (Optional)
Ground Control Points (GPC) which improves accuracy, press
to
Load them under the GPC tab.
5. Otherwise Click the
Advanced Tab. ENVI
programmatically calculates
Geoid Correction based
on the Earth Gravitational
Model (EGM) 1996. Accept
the default or input your
own Geoid Correction if
it is more accurate.
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7. Click the Export Tab.

ORTHORECTIFY

6. In this process we will set the Image Resampling method to Cubic
Convolution. Compare other methods as you deem necessary.

8. Click Browse to navigate to
your desired output directory.
Name your output
<YOUR_FILE>_ortho.dat.
9. Optionally toggle Preview
to open a movable portal to
visually inspect results. Click
Finish.
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ORTHORECTIFY
23

Before & After Ortho-Examples:

PANCHROMATIC SHARPEN
METHOD 1
1. Open your low res (ms) – multi-spectral
image in an ENVI view.
2. From the Toolbox, Search for NNDiffuse
or select Image Sharpening > NNDiffuse
Pan Sharpening. The NNDiffuse Pan
Sharpening wizard will appear.

Pan Sharpening is an image merging process that allows users to create a
new image by combining hi-res grayscale images with low-res color images
to produce a color image for literal analysis. ENVI provides multiple methods.
Only Two of many have been selected for this guide as a basis for conceptual
understanding. Proceed with Method 1 if your images DO NOT require
co-registration or atmospheric correction. Otherwise use Method 2.
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PANCHROMATIC SHARPEN

3. Next select the ellipses button
next to the Input High
Resolution Raster.
4. Click
and navigate to your
hi res panchromatic image in
the File Selection Window.
5. Click OK on the File Selection
Window.
6. In ENVI, use
marquee zoom
to zoom in on any area of your
currently loaded low res ms image.
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8. See the ‘before & after’
samples provide.

PANCHROMATIC SHARPEN

7. Next check Preview in the NNDiffuse Pan Sharpening Window. This
will allow you to visually inspect results before processing the data.

9. If you are satisfied with the
Preview results Click OK in
the NNDiffuse window.
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PANCHROMATIC SHARPEN
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Before & After NNDiffuse Pan Sharpen Examples:

1. Open both images, hi-res panchromatic and low res – multi-spectral in ENVI.
2. From the Toolbox, select
SPEAR > SPEAR Pan
Sharpening. The Pan
Sharpening wizard will
appear.

PANCHROMATIC SHARPEN

METHOD 2

3. Click the Select High Res File
choose your panchromatic
image then click OK. Next
click Select Low Res File,
choose your multispectral
image then click OK.
In this workflow images will be co-registered
and atmospherically corrected beforehand.
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PANCHROMATIC SHARPEN

4. The Low Res Band Matching
Choice dialog will open. It is
best practice to choose Band
3 because spectral properties
in the red band closely match
those of panchromatic images
and eases co-registration.
Click OK.
5. Click Select Output File,
navigate to your desired
output directory and name
the file *_pansharp.
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PANCHROMATIC SHARPEN

6. Your window should resemble the following Pan Sharpening wizard.
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PANCHROMATIC SHARPEN

7. Click Next. In the following window
toggle Select tie points automatically.
8. Next ensure Use seed points is
checked and Click Auto-Generate
Seed Points. This allows ENVI to
estimate GCP’s. Alternatively you
can choose your own by clicking
Select Seed Points.
9. Your window should resemble the
following Pan Sharpening wizard.
10. Click Next. A series of windows
will open in addition to the Pan
Sharpening wizard. Bring the
Image to Image GCP List forward.
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11. Click Options > Order Points
by Error and the seeds with
the highest RMS Error are then
brought to the top of the list.
12. Highlight Seeds with RMS Error
higher than 3 and Click Delete.
13. Next bring forward the Pan
Sharpening wizard and set
Maximum allowable RMS per
GCP: to 1.0 and click Apply.

PANCHROMATIC SHARPEN

14. Choose Warp Parameters you desire. In this exercise set Method: to
Polynomial and Interpolation: to Cubic Convolution then Click Next.
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PANCHROMATIC SHARPEN
33

15. In the final Pan Sharpening wizard window choose Sharpening Method.
In this exercise select Gram-Schmidt and Click Next. Once Processing
is complete Export the image to NITF or click File > Save Image As on
Classic View # 1 to save as an image file or a postscript file.

CHANGE DETECTION
1. Click the Open File icon
in ENVI and open two images
over the same geographic region on different dates.
2. From the Toolbox, select Change Detection > Image Change Workflow.
The Image Change wizard will appear.
3. Click the Browse next to Time #1 File and select the oldest/first image. Click OK.
Steps laid out in this section result in the production of a 2-Color Multi
View (2CMV) Change Detection. The end product will be a standard red
and blue image based on changes that have taken place between images
captured on two separate dates. Remember the phrase “red has fled” and
“blue is new”. ‘This exercise assumes the images are already co-registered.
If your image is not co-registered do so before proceeding.
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CHANGE DETECTION
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4. Repeat previous selection steps for Time #2 File but select
the newer/second image. Then Click Next.
5. The Image Registration
window will appear.
If your images require
registration toggle
Register Images
Automatically.
Otherwise toggle
Skip Image
Registration.

7. Toggle Image
Difference then
Click Next. Accept
the default Difference
of Input Band and
Band 1 under Select
Input Band and Click
Next.

CHANGE DETECTION

6. Click Next and the Change Method Choice window will appear.
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CHANGE DETECTION
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8. The Thresholding or Export window will appear next.
Accept default Apply Thresholding and Click Next. The
Change Thresholding window will appear allowing you to
either enter a Manual threshold or use Auto-Thresholding.

CHANGE DETECTION

9. Under Select Change of Interest you may choose Increase
and Decrease, Increase Only or Decrease Only. Increase and
decrease will return both red and blue 2CMV. Red indicates
decrease and blue indicate increase (red has fled, blue is new).
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CHANGE DETECTION
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10. Under Select Auto-Thresholding Method accept default Otsu’s. For
a comprehensive explanation of Otsu’s, Tsai’s, Kapur’s and Kittler’s
thresholding methods visit ENVI Tutorials online. Click Next.
11. The Cleanup window
will now appear
enabling you to
refine results. Accept
the defaults and
Click Next or toggle
Preview and manually
tune to your liking.

CHANGE DETECTION

12. The Export window will now appear allowing you to save both image
and vector outputs. Click Browse on both the Export Change Class Image
and Export Change Class Vectors and navigate to your output directory.
Name the output files appropriately Click Open then Click Finish.
13. Y
 ou may now use the transparency slider to visually inspect the results.
Old Image, New Image, Change Detection Examples:
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ANOMALY DETECTION
1. Open your image in ENVI thru the
data manager or by dragging and
dropping from a Windows Explorer
or ArcCatalog.
2. From the Toolbox, Click > Anomaly
Detection > Anomaly Detection
Workflow. The Anomaly Detection
wizard will appear. Click Next.
Anomaly detection is a process performed on imagery to highlight
significant or unnatural spectral differences in pixels versus neighboring
values. Anomaly detection is useful in determining things such as disturbed
earth or spikes in energy levels versus surroundings, for example. This
process is useful in narrowing down searches to determine if and where
further investigation is warranted.
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4. Accept Global under
Mean Calculation
Method to process
the spectrum of the
full dataset. Suppress
Vegetation if your image
deems it necessary.
Click Next.

ANOMALY DETECTION

3. Select RXD-UTD algorithm under Anomaly Detection Method. For a
detailed explanation of this and other algorithms for this workflow
visit the ENVI Documentation Center online.
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ANOMALY DETECTION

5. Ensure Anomaly Percentage Threshold is set to default 0.05 or adjust
thru trial and error using the Next and Back buttons to your liking. The
higher the threshold is set, the more data will be perceived as defects.
Experiment with the Preview checkbox. Click Next.
6. On the Export window
use the Browse button to
specify output filenames
for both your new anomaly
image and vector datasets.
Click Finish.
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ANOMALY DETECTION

7. The results will
automatically open
in ENVI for further
investigation and/or
exploitation. White in
the imagery indicates
an anomaly. Red in
the vector indicates
an anomaly.
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ANOMALY DETECTION
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Input Image, Anomaly Image overlayed with Anomaly Vector Examples:

TERRAIN CATEGORIZATION
1. Open a color image in ENVI
for classification.
2. From the Toolbox, Click
Classification > Classification
Workflow. The Classification
wizard will appear. Click Next.
3. In the next window toggle
Use Training Data to signify
this is a ‘Supervised’
Classification. Click Next
ENVI provides the Classification Workflow to allow user to create a
Landcover / Terrain Categorization (TERCAT). This process can be carried
out by the software, ‘Unsupervised’ or by user assigned ‘Spectra, ‘Supervised’’.
In this exercise we will conduct a ‘Supervised’ Classification.
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TERRAIN CATEGORIZATTION
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4. The Supervised Classification window will appear. You will use the
to add Training Data classification(s). Assign Class Names per
region to the right under Properties tab. Delete training data if
necessary by highlighting item by item and pressing .
5. Once desired classes
have been created
highlight one by one
and go about the
image to select spectra
samples for each
class using the ROI
Annotation tools in
tandem with the
navigation tools to
zoom and pan around.

7. Select 8 to 10 varying spectra for
each class by simply drawing a
polygon or rectangle then Right
Click and select Accept or Delete.

TERRAIN CATEGORIZATION

6. The mouse wheel is very useful
in allowing users to zoom in and
out based on the cursor position
while in annotation mode.
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TERRAIN CATEGORIZATTION
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8. Once satisfied with spectral selection toggle the Preview box to launch a
Portal within View one to inspect results so far. Drag the Portal around
the View to inspect.

10. Click Next and the
Cleanup window
will appear. This
window allows user
to use smoothing
algorithms to
generalize if
desired. Adjust or
accept Defaults
and Click Next.

TERRAIN CATEGORIZATION

9. If you are not satisfied with Preview results you may use the icon to
go about the view selecting and deleting specific ROI’s if there is an
issue.
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TERRAIN CATEGORIZATTION
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11. On the Export
window use the
Browse button
to specify output
filenames for both
your new anomaly
image and vector
datasets. Click
Finish.

TERRAIN CATEGORIZATION

Input Image, New Image & Vectors TERCAT Examples:
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EXPORT TO RPF
1. G
 enerate a GEOTIFF with specialized vector
overlays, drawings, pictures and/or text
annotations. This can be accomplished in ENVI
using the Annotations menu or ArcMap as
long as the GEOTIFF is accompanied by a
corresponding World File.
2. In ENVI Open the newly created GEOTIFF
by selecting File > Open and navigate to
the location on disk.
ENVI enables creation of the following RPF/CADRG Resolutions:
(1: 5,000,000 GNC (754m), 1: 2,000,000 JNC (300m), 1: 1,000,000 ONC
(150m), 1:500,000 TPC (75m), 1: 250,000 JOG (37.5m), 1: 100,000 TLM
(15m) and 1: 50,000 TLM (7.5m). Quality will depend on scale and dpi of
the input so take this into account during data preparation.
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EXPORT TO RPF

3. Right Click the newly opened file and select Zoom to Layer Full Resolution.
Visually inspect the GEOTIFF. Next Zoom to Layer Extent. if you are not
satisfied with the visual inspection make necessary adjustments such as
dpi, overlays etc then export again before proceeding.
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EXPORT TO RPF

The GEOTIFF in this example was created in ArcMap at Scale 1: 25,000.
When satisfied with the overlaid graphics and annotations, it was
exported from Data View as a TIFF with Write World File toggled on
the General Tab and Write GeoTiFF Tags toggled under the Format
Tab. A 200 DPI was used.
4. Click File > Save As >
CADRG assuming you are
satisfied with the newly
created GEOTIFF.
5. Highlight your GEOTIFF
under Select Input File.
6. Click the OK Button.
7. The RPF (CADRG) Output
Parameters dialog box
will open.
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EXPORT TO RPF

8. Choose your desired Output
Directory. Set your desired
Resolution from the drop
down menu. In this example
1: 50,000 TLM Resolution
was chosen.
9. Complete (Optional)
Classification, Country
Code and Release metadata.
10. Choose IMG2RPF as the
Producer Code.
11. Click OK.
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EXPORT TO RPF

12. Once processing is complete navigate to the output directory
and ensure you have the RPF data and the A.TOC.
13. Your Output directory’s
contents should look similar
to the example to the right.
14. Visually inspect the newly
created RPF data using
Falconview. If dissatisfied
make refinements and
repeat the preceding steps.
Once satisfied burn the
entire RPF folder including
the A.TOC file to disk to be
loaded onto military aircraft
and/or ground vehicles
which rely on RPF data.
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EXPORT TO RPF

Results displayed in Falconview:
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GEOSPATIAL DATA,
ANALYTICS, AND
CUSTOM SOLUTIONS
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From sensors and software to actionable
information, Harris Geospatial Solutions
helps you make informed decisions – when
and where they are needed.

HarrisGeospatial.com

